1 Reply Latest reply on Mar 7, 2011 1:08 PM by philmodjunk

    Change Import Field Mapping in 90 field count



      Change Import Field Mapping in 90 field count


      I am trying to help a friend to import data from an Excel spreadsheet to FM 10. The person who did the origional FM design is no longer available. She has a Mac. I have a PC and no FM or FM experience. I have limited access to her system.

      The problem is with the mapping of the feilds durring the import of a CSV file.  There are about 90 fields. It appears that a field was added near the top of the Excel file after the import mapping was last corrected. When I move a field it moves the replaced field down to the bottom. It is obviously tedious to move a field near the top of the list. The Excel file should not be changed.

      Is there a way to do an insert instead of replace while changing the mapping when importing a CSV file? Only one person will import the data so will the mapping stick once it is corrected?

      Reading posts in the Fourm I notice metions of scripting the import. There is an Import button so I assume there is a script. I have not had a chance to see if I can figure out how to view the script and what it does.

        • 1. Re: Change Import Field Mapping in 90 field count

          Yes, re-mapping the fields to align for the newly added column can be very tedious if you have to drag field names around to align them correctly.

          If the first row of your spreadsheet contains column headers with exactly the same name as your fields in FileMaker, you can select "Don't import first row" and then select the matching names option from the arrange by drop down to automatically align all fields by name.

          An import button definitely means that you have an import script. You can enter layout mode and double click the button to find out the name of the script performed by the button. You can then open Manage Scripts to find and update this script. If you open the script for editing you should be able to find the import scripts step where you can click the step to select it, then click the specify button at bottom right to open up the same field mapping dialog. You should be able to correct this misalignment of the field mapping there once and then see this order retained until the next time the excel file's layout is modified.