1 Reply Latest reply on Mar 1, 2013 9:18 AM by philmodjunk

    Chart Help – Chart 2 is not displaying correctly

    netguykb

      Title

      Chart Help – Chart 2 is not displaying correctly

      Post

            

           I have two separate layouts that display chart data. The first chart only displays data based on current record. The data source chart data = Current Record (delimited data) AND data format = percent. This chart displays the way I would like it.

            

           The second chart displays data based on all records. The data source chart data = Current Found Set AND data format = percent. This chart is not displaying correctly. The % numbers are not displaying correctly (formatting is incorrect), they are much higher than what I want even though the data source is exactly the same.

            

           If I set the format as "As entered" or "Decimal" then its fine BUT I would like percents to display not just a number.

           Here is how the data is being stored in the database. No other calculations are being performed in the chart preferences

           rank_analytics_percent (type calculation, number)
           Round ( rank_analytics / rank_analytics_tot_possible * 100 ; 1)

           The other two fields are also being calculated:

           rank_analytics (type calculation, number)
           ExecuteSQL("select sum(F.sf_weighting) from x_vendor_component_function F join Vendor V on V.ven_id = F.ven_id where F.current_capability = 'Yes' and F.sc_id =4 and V.VEN_ID = ?"; "";"" ;Vendor::VEN_ID)

           rank_analytics_tot_possible (type calculation, number)
           ExecuteSQL("select sum(F.sf_weighting) from x_vendor_component_function F join Vendor V on V.ven_id = F.ven_id where F.sc_id =4 and V.VEN_ID = ?"; "";"" ;Vendor::VEN_ID)

           Any help would help in order to display % calculations 100’s not 1000’s