0 Replies Latest reply on Sep 21, 2009 6:29 AM by bmw

    comma as decimal point - confusion

    bmw

      Title

      comma as decimal point - confusion

      Post

      In Denmark, we use comma as decimal point. My Mac OS 10.6 is so set pt.

      I recently upgraded to FM7 from FM5.

      I have a database with individual preparations of - you don't care, stuff -  where I record their concentrations.

       

      Over the years I have, for whatever reason (probably Excel-related), decided to use period as the decimal point, but of course I slip up occasionally and enter commas.

      Sometimes I have set a custom system-setting with period as decimal and everything else Danish.

       

      Now, when I open several databases I am asked whether I want to use file or system-setting. I think I chose system setting. I now see periods in my numbers - except I see some question marks, and when I click there, I see I have commas as decimal points. Upon change to period, calculations look correct and I can see the number.

       

      But my system setting is for commas.

      I've quit and restarted and reopened, but I don't get the 'use file or system setting'-dialog any more; and I cannot see the 'use system formats' item in the format menu - probably because I am (using system formats).

       

      I have tried to search for commas searching for *,* in the relevant field. This found 44 of 4500 records. Some of these have numbers with periods, some have the question mark.

      When I click in the field, all have commas.

      How come they are displayed differently?

       

      So I am completely confused. What is written in stone and how is it revealed? Can I change the number format by changing the system-setting - it does not appear so? 

      Is there a good description of that? I tried searching,but the little I found way way above my head.....

       

      I'd much appreciate a pointer.....

       

      bmw