1 Reply Latest reply on Jun 12, 2013 1:50 AM by PeterMontague

    comma as decimal point - confusion

    bmw

      Title

      comma as decimal point - confusion

      Post

      In Denmark, we use comma as decimal point. My Mac OS 10.6 is so set pt.

      I recently upgraded to FM10 from FM6.

      I have a database with individual preparations of - you don't care, stuff -  where I record their concentrations.

       

      Over the years I have, for whatever reason (probably Excel-related), decided to use period as the decimal point, but of course I slip up occasionally and enter commas.

      Sometimes I have set a custom system-setting with period as decimal and everything else Danish.

       

      Now, when I open several databases I am asked whether I want to use file or system-setting. I think I chose system setting. I now see periods in my numbers - except I see some question marks, and when I click there, I see I have commas as decimal points. Upon change to period, calculations look correct and I can see the number.

       

      But my system setting is for commas.

      I've quit and restarted and reopened, but I don't get the 'use file or system setting'-dialog any more; and I cannot see the 'use system formats' item in the format menu - probably because I am (using system formats).

       

      I have tried to search for commas searching for *,* in the relevant field. This found 44 of 4500 records. Some of these have numbers with periods, some have the question mark.

      When I click in the field, all have commas.

      How come they are displayed differently?

       

      So I am completely confused. What is written in stone and how is it revealed? Can I change the number format by changing the system-setting - it does not appear so? 

      Is there a good description of that? I tried searching,but the little I found way way above my head.....

       

      I'd much appreciate a pointer.....

       

      bmw

        • 1. Re: comma as decimal point - confusion
          PeterMontague

               I have a similar problem. We sell our products on the Spanish market. We need to use commas in decimals. I have used the subsitute function to replace the period with a comma. This works well when we export our records. But it doesn't work when I show the Spanish prices on the layout. The field contains a "?". I've gone into the inspector and chosen the data format of currency and set the decimal separator to "," and to ".". Both of these put the decimal separator in the wrong place. 

               The data is exporting correctly. But I'd like to see exactly what is going to be exported in currency format.