9 Replies Latest reply on Jun 27, 2014 4:46 PM by dklein@tgroupmail.com

    Conditional Value List from Self Relationship (Port of relationship fine, but value list isn't...

    dklein@tgroupmail.com

      Title

      Conditional Value List from Self Relationship (Port of relationship fine, but value list isn't filtering)

      Post

           HI All,

           I have a database of assets where I have a case that there may be a group of assets inside another asset. For instance, we are tracking "tapes" that are stored in "pelican cases", but the tapes, can be checked out on their own. What I'm trying to setup here is self-join relationship to fill a value list with the "pelican cases"

           So I've got an Asset's table and a second table occurrence of this table called "Value List".  In the asset's table there is a field called "Category" that is populated with each type of asset. There is also a field called "_storagecase_cat_Filter" that is a text field that auto calculates to "Storage Case". The relationship between "Value List" and "Assets" is set to be "Category = _storagecase_cat_filter".

           Now, if I place a portal on our Asset layout to see that the relationship is performing as I want, it is. Only the pelican case assets that have a Category of "Storage Case" appear in the portal.

           When I go to setup the Value list, so show the values from this relationship, I have issues.

           First, I've tried creating a value list with using the values from the "Value List" table occurrence. I have the first field set to the Unique ID of the record for the asset, and the second field set to the asset's name. If I include all values in this list, when I go to use it for a popup field, every single asset appears as a possible value in the popup field, not just the ones limited by the relationship.

           If I modify this value list so that it includes only related values from "Assets", I'm getting a "No Value Defined Error".

           Now if I set the value list to pull values from the Assets table and only include values from the "value List" relationship, I still get the "No Value Defined Error". 

           I'm sure I'm just missing something silly, but I can't seem to pinpoint the error.  Any help would be much appreciated.

            

           Thanks!