11 Replies Latest reply on Jun 7, 2013 8:08 AM by philmodjunk

    Container Fields Not "Interactive" After Migration

    ktalley

      Title

      Container Fields Not "Interactive" After Migration

      Post

            

           Hello,

            

           I recently migrated a FM11 database to FM12. I haven't noticed any hiccups the past few months until I tried to create a container field that has interactive content. I'm wanting to view PDFs in the container field. When I mark the container field to "optimize for interactive content" in layout mode, the Insert Menu does not display PDF or Audio/Video after selecting the container field in browse mode. However, if I create a new database in FM12, the interactive nature of a container field works as expected.

            

           Could this be a problem with the conversion? I have tried creating new container fields in a few different tables with the same results. The file is hosted by FMS, but it still does not work when I try on a local copy. I have the same issue on Mac OS 10.8 and Windows 7. Thank you for your suggestions.

            

           kt

        • 1. Re: Container Fields Not "Interactive" After Migration
          schamblee

               Container fields are handled a little different in 12 than 11.  I believe you need to export the file then import back into the container.

          • 2. Re: Container Fields Not "Interactive" After Migration
            philmodjunk

                 By any chance is the container field located inside the row of a portal? The interactive options don't work inside a portal.

            • 3. Re: Container Fields Not "Interactive" After Migration
              ktalley

                   Thanks for your replies. The containers are not in a portal. Even when I create a new container field and place it on a new layout, I'm not getting the options in this database as I do in a new database under the insert menu. Could this be a signal of a structural problem with the database?

                   Thanks for your ideas.

              • 4. Re: Container Fields Not "Interactive" After Migration
                schamblee

                     You might try to run recover on the database, to check for errors. 

                • 5. Re: Container Fields Not "Interactive" After Migration
                  ktalley

                       Thanks - although I'm not liking the direction I'm heading...

                       I converted a copy of the FM11 database from July with the same results, so whatever the problem is, it's probably existed for a while. I ran a full recover and it did find errors. In the recovered file, the container issue still exists. I know I couldn't use that one for production anyway even if it fixed it, so I guess I'm stuck with an unsavory option.

                       Any quick and safe way to recreate a database? I've got 367 layouts, 50 tables, 246 relationships, and 681 scripts. I have no idea if that is a lot or not, but since I'm not a full time developer, I'm sure it's going to take me some time to replicate. I read either here or fmforums.com that you shouldn't even copy and paste anything (layouts, scripts, etc.) between a damaged database and a new one. Is that standard practice?

                       While this container issue is not a deal breaker, I'm concerned there are other problems waiting to be discovered. I hope there is another solution, but I have a sinking feeling there isn't one. 

                       Thanks for your help.

                  • 6. Re: Container Fields Not "Interactive" After Migration
                    philmodjunk

                         Please check the following steps and see if any differ from what you have tried.

                         create a brand new database file with a container field.

                         Put that container field on a layout based on the table where the container field is defined.

                         Do not put it in a portal row.

                         Select that field while in layout mode.

                         Use the Data tab in the Inspector to select the "optimize for interactive content" option.

                         Enter browse mode.

                         Click on the container field to put the focus in the container field.

                         Pull down the insert menu.

                         Do you see the option for Insert PDF enabled?

                         If that works, then create a brand new layout based on your table where the container field is defined and repeat the above steps to see if that works.

                    • 7. Re: Container Fields Not "Interactive" After Migration
                      ktalley

                           Okay. I followed your steps. In the new, test database the container works as expected; I see the option for insert PDF and I can sucessfully insert and view the PDF.

                           When I create a new layout in the orignial database and take the same steps, I do not see the insert PDF option.

                           I'm not sure if this is what you meant for me to do as the last step, but when I add a TO to the test database that points to the original database's table and choose a container field from that table, it gives me the option to insert a PDF (from the new, test database). When I do insert a PDF, it works as expected in the test database. If I view that same containter from the original databae (in a new layout), I can view the PDF, but the insert PDF option is still not there. Strange. Does that make sense?

                           Thanks for helping me.

                      • 8. Re: Container Fields Not "Interactive" After Migration
                        philmodjunk

                             One of my other suggestions was:

                             Open the original, problem file.

                             Enter layout mode.

                             Select new Layout from the layout menu.

                             Use the field tool to add the container field to this layout, do not copy and paste this field from an existing layout. Enable interactive optimization, enter browse mode and test.

                             If this new layout works, it may be that your original layout is damaged and that you can correct this issue by rebuilding your original layout "from scratch".

                             You might also run a recover on your file and test the recovered copy (even if recover does not report fixing any issues).

                        • 9. Re: Container Fields Not "Interactive" After Migration
                          ktalley

                               I've tried a new layout, new field, and even a new table in the original database - none of which worked. I also ran a repair, which did find some errors, but the result is the same on the repaired copy. 

                               I created a clone of the database and can copy that to my dropbox account if anyone wants to take a crack at it. I've removed all of the users that I entered. If there is anything I should be mindful of before uploading, I would be happy to make those changes. Thanks

                               kt

                          • 10. Re: Container Fields Not "Interactive" After Migration
                            ktalley

                                  

                                 I still haven't found a solution to the container field not working properly, but I have found the cause of the errors the recovery utility was finding. Slightly off-topic, but possibly related:

                                 I decided that if I was going to have to spend several hundred hours rebuilding a solution from scratch, that I could invest a few hours to see if I could clear up the errors the recovery tool found. I copied each table one at a time to a new database then ran the recover command after each one. I found 2 tables that were the cause of the errors and eventually 6 fields within those two tables. When I eliminated those fields, the recovery utility did not find any errors and said the database was "safe to use." I still feel a little uneasy using the database, but I don't feel quite as panicked as when I knew there were errors. I'm not going to use the recovered database, but the original one with the offending fields removed. 

                                 However, none of this fixed the container fields not being interactive. I even removed the offending fields from the v11 database and did another upgrade with the same results. I know there is obviously a good chance something is still wrong even though the recovery tool says there are no errors. 

                                 If I delete all the tables and all the layouts, create a new table with a container field, and create a new layout, I still cannot make a container interactive in the original database file. But when I create a brand new database it works as expected. Very strange. 

                                 On the upside, after researching how to prevent database corruption, I'm going to stop some very bad habits in which I've been participating that probably led to this issue.

                            • 11. Re: Container Fields Not "Interactive" After Migration
                              philmodjunk

                                   You are welcome to post a down load link from drop box if you want others to examine your file, but given that you had some "very bad practices" it may be that there is an issue with your file that Recover cannot detect or repair.