4 Replies Latest reply on Apr 21, 2014 11:56 AM by DebraFenzl

    Content Management thumbnail layout doesn't show images after importing file

    DebraFenzl

      Title

      Content Management thumbnail layout doesn't show images after importing file

      Post

           I apologize if this has been answered.  I have been searching the forum for several days.  

           I am a Bento 4 user, new to filemaker pro 13 (using trial version to see if I can handle it).  I have decided to use the starter solution Content Management for the thumbnail layout.  

           When I import my bento file, the images do not appear in the thumbnail layout. The images do appear in the content list layout. I also tried converting the bento file to excel and importing then adding the images and still did not work.  

           But, when I make a new record, and add an image, the image does appear in the thumbnail layout.  

           How do I get the images to show in the thumbnail layout, without having to reenter the entire database.

           Thank you in advance.

            

            

        • 1. Re: Content Management thumbnail layout doesn't show images after importing file
          philmodjunk

               How did you get the images into the content management table? Did you import them? If so, did you enable auto-enter options during the import?

               Check to see if the clumsily named CONTENT ID MATCH FIELD has a value for your images.

          • 2. Re: Content Management thumbnail layout doesn't show images after importing file
            DebraFenzl

                 The first way I got the images in was with the bento file import.  

                 The second way was exporting my bento file to excel, importing the file to filemaker and then drag and drop images to the "file container" in the contents details form.        

                 I didn't know what to do with CONTENT ID MATCH FIELD, when viewing the field details it says "Indexed, Auto-enter Serial".  I created all my own fields when importing.  

                 What is CONTENT ID MATCH FIELD and did my import override something in it?

            Thank you

            • 3. Re: Content Management thumbnail layout doesn't show images after importing file
              philmodjunk
                   

                I created all my own fields when importing.

                   I sincerely doubt that you did anything of the kind. More likely would be that you created a brand new set of records during import.

                   I do not know for sure that this is the issue or not as this starter solution used a truly creative method of setting up the Thumbnails fields and layout and I haven't taken the time to explore every nuance of it.

                   But what I have suggested is to check the value in the CONTENT ID MATCH FIELD on each of your records. You can do this by entering layout mode on the Content Details layout and using the Field Tool or the Field Picker to add this field to the layout so that you can see the actual value in it. There should be a number in this field--a serial number that was auto-entered when each new record was created. What you don't want is for this field to be empty--which shouldn't happen for drag and dropping documents into the container field, but might happen if you used Import Records | Folder to import the files into the file..

              • 4. Re: Content Management thumbnail layout doesn't show images after importing file
                DebraFenzl

                     I put that field onto my layout.  It is empty, but I can enter data.   I didn't use it when importing as I didn't need a serial number or any numbering of my data.

                     Could you please explain what that field is for.  

                     Thanks