AnsweredAssumed Answered

Copy field data into a join table field

Question asked by remoran_1 on Oct 12, 2010
Latest reply on Oct 12, 2010 by remoran_1

Title

Copy field data into a join table field

Post

I am having trouble trying to paste field data into an ID field in a join table. The DB works without a problem and the relationship works beautifully but I cannot paste the ID into the join table field after performing the find on the desired records. I tried Replace Contents on the found set, which seemed to work but, in actuality, did nothing. Tried set field via script manager but the calculation setup says the table cannot be found even thought the many to many relationship via the join table works perfectly in the system. I can do a control paste into the join table id field and the related record loads beautifully but doing this 6000+ times is a non starter. Any help would be great. Lastly, the join table ID field is a lookup into the source table that contains the ID. Also tried this script given to me by an FM user far more expert then I in the scripting side of things. :) Set Variable [ $id; Value:_Primary_id ] Go to Layout [ “New Layout” (YourTable) ] Enter Find Mode [ ] ...Set your find criteria Perform Find [ ] Replace Field Contents [ _foriegn_id; Replace with calculation: "$id" ] [ No dialog ] This also seem to work as per Replace Contents but it also does nothing. Any help on this would be terrific. TIA remoran

Outcomes