3 Replies Latest reply on Nov 16, 2013 6:04 PM by philmodjunk

    Copy Image

    johnw54

      Title

      Copy Image

      Post

           I have a thumbnail layout, and a larger image layout.  When i click on the thumbnail it takes me to the larger image layout and visa versa.  However, I have put a button on the larger image which copies it to the clipboard. After it is copied to the clipboard and when I click on the large image to go back to the thumbnail page nothing happens.  I tried halt and exit script and neither seemed to do the trick.  Any ideas?

        • 1. Re: Copy Image
          philmodjunk

               And what script are you using to copy to the clipboard and to change layouts? Is this all in one window or do you open a second window?

               To post a script to the forum:

                 
          1.           You can upload a screen shot of your script by using the Upload an Image controls located just below Post A Answer.
          2.      
          3.           You can print a script to a PDF, open the PDF and then select and copy the script as text from the opened PDF to your clipboard for pasting here. (with this approach, you can get multiple script steps on the same line, please edit the pasted text by inserting some returns to separate those steps.)
          4.      
          5.           If You have FileMaker Advanced, you can generate a database design report and copy the script as text from there.
          6.      
          7.           If you paste a text form of the script, you can use the Script Pretty box in the Known Bugs List database to paste a version that is single spaced and indented for a more professional and easier to read format.
          • 2. Re: Copy Image
            johnw54

                 I am using a go to layout in both instances.   I am using the copy script step to copy.  Its happening in one window. Funny thing is that on the large image layout there is a button to press that takes u back to the thumbnail layout using the same script as clicking on the image and it works but clicking on the image does not work if you have previously clicked on the button that runs the Copy script step.  

            • 3. Re: Copy Image
              philmodjunk

                   So:

                   is the container field set up as a button or do you use a script trigger to perform a script to go back to the other layout? I suspect that you are using the OnObjectEnter trigger. The copy button is leaving the focus in the container field and thus the trigger is not tripped when you click in it.

                   If my guess is correct, all you need do is add a commit record step after the copy step and your script trigger will be tripped consistently.