3 Replies Latest reply on Aug 7, 2014 4:06 PM by philmodjunk

    Creating a new field - why doesn't the field "save?"



      Creating a new field - why doesn't the field "save?"


           Hello there. I'm sure this is a very straightforward issue, but for some reason I can't get new fields to save in FMP.

           The database I'm working with has a couple of drop-down menus, and in the past, we could add new fields to the drop-down by typing it in. New records would include that field in their drop-down.

           For some reason, it's no longer saving. The previous record has the new field, but it doesn't carry into the drop-down for new records.

           Any suggestions on what we're doing wrong?

           Thanks in advance ~

        • 1. Re: Creating a new field - why doesn't the field "save?"

               There's some confusion of terms here. You aren't and can't "add new fields" to a drop down. You can add new values to the drop down's value list. Whether or not you are permitted to do that can depend on how you have designed your value list and your layout.

               You might also check to see if the field formatted with this drop down is a text or a number field when you check its type in Manage | Database | fields.

          • 2. Re: Creating a new field - why doesn't the field "save?"

                 Oh, that makes sense - thank you for clarifying. The field is definitely formatted for text, but I don't think I could check in any case - when I go to File>Manage, all the next options (Database, Value Lists, etc.) are greyed out. I didn't set up this particular database - does this mean I lack admin privileges to access it? Or does it only become selectable after you click something?

                 Sorry, I realize the problem I'm describing must seem vague. You can type in a new value and it'll save for that record, it just won't save to the value list.

            • 3. Re: Creating a new field - why doesn't the field "save?"

                   It does not sound like you have full access to this database and that is what you need to pursue a solution to this issue.

                   Please note that I did not say that the field must be formatted as text but that it should be a field defined as having the text data type--a setting specified in Manage | database | Fields. It is unlikely though that this is the reason why your value list is not functioning as expected.

                   But to pursue this further, you 'd need to enter layout mode, select the field and then check the options specified in the inspector's data tab and from there, open up  manage | value lists to check what was specified for your value list.