5 Replies Latest reply on Feb 27, 2015 11:03 AM by FentonJones

    CSV imports first line only

    PeterPan

      Title

      CSV imports first line only

      Post

      So I have a bunch of CSV files that I'm importing, and for some reason it will only import the first line.  Funny thing is, I open the CSV, save it (no changes made) and then it imports the whole file.

      Any ideas?

        • 1. Re: CSV imports first line only
          philmodjunk

          Sounds like there is a file format issue that corrects when you open/save the file. Returns are used in CSV to separate one record's data from another so I suspect that some other character such as the vertical tab is undergoing a font substitution to become a return when you open the file in whatever text editing App you use to open it.

          • 2. Re: CSV imports first line only
            yomango

            Hello, I have a question about  importing the so called CSV files. I have several files I want to import into FileMaker. The files do not show if I choose to open the file type as CSV, I have to choose "All Files" to see them, nevertheless the files are comma delimited and opens with the W8 Notepad (see screen shot). Anyway, my problem is that the records import all but the first one (first line) because the import option "Do not Import first record contains file names" is marked but grayed out, not allowing me to un-check it. If I go to the CSV file, create and save a blank line before the first written line, the importing is done correctly. Can anyone tell me how to get FM to import all records from the CSV and not to ignore the first one

            • 3. Re: CSV imports first line only
              FentonJones

              Is it possible that your Import option (first choose, at bottom of layout) is "Merge Files" (which is the default I think)? Because such means that the 1st row is the field names by default (with no change available). Others, such as "Comma-Separated" should allow that option to be turned off (default).

              • 4. Re: CSV imports first line only
                yomango

                Hello, Fenton. Thank you for your interest on advising me. No, as I said, the only way I can see the file names to import is if I choose "All files" type. Files don´t show if I choose Merge, Comma Delimited, Excel, etc. And the option not to import first record remains  ckecked and dimmed out

                • 5. Re: CSV imports first line only
                  FentonJones

                  What is the file extension? (.csv, .txt, etc.). If it a simple file you can often manually change the extension, so that FileMaker is happier with it.