AnsweredAssumed Answered

Cursor and focus not shown after script?

Question asked by disabled_JustinClose on Dec 3, 2013
Latest reply on Dec 3, 2013 by disabled_JustinClose

Title

Cursor and focus not shown after script?

Post

     OK, I swear I have done this before, but my efforts all appear to be for naught.

     I am trying to get the focus and the cursor to show up in a field after switching tabs (hidden tab).  The field is a standard edit box; it is global field; it is empty to begin with.

     I have tried the simple "go to field"; the field activates, but the cursor does not appear to be in the field.  HOWEVER, if you start typing (even though it doesn't look like the cursor is there) and THEN click into the field, whatever you type DOES show up in the field.

     I have tried "set selection" without luck.  (Could be I am using it wrong; I have tried setting Start="", End = 1; Start = 0, End = 0; Start = 1, End = 1).

     I have tried "insert text", both with a blank text and with placeholder text, ala "<enter text here>".  Again, it doesn't LOOK like the cursor is there but if you start typing anyway, and then click into the field, whatever you typed (in addition to the inserted text) shows up.  Also, even if you don't type anything but just click into the field the inserted text shows up (when the field was blank before).

     I attached the various script steps I have tried in an image.

     Any suggestions?
      
     Thanks,
     J

FieldFocus_script.png

Outcomes