4 Replies Latest reply on Jun 27, 2013 10:52 AM by philmodjunk

    Custom Search not working properly

    j_morris

      Title

      Custom Search not working properly

      Post

           I have created a custom search layout that uses global fields and allows the user to enter information into 3 fields. The global fields are part of their own table within the database. The user can just enter data in one, two or all of the fields depending on what they are searching for. The first two fields use dropdown menus with constant data that they can choose from. The last field is for them to enter a 4 digit year.

           The problem is that after they enter the year, the next step would be to click on the "Find" button whose script opens a new window, goes to a specific layout, enters find mode, sets the fields and performs the find. I have attached a screengrab of that script. When this happens the value entered in the year field does not get stored unless the user were to click outside of the field (like on the background or another field) before clicking on Find. Just clicking on Find button does not work.

           I've tried applying script triggers for the Year field with OnObjectExit or OnObjectValidate with a script that uses Commit Records/Requests but neither worked.

            

           Any help would be greatly appreciated!

      Edit_Script__Perform_Find__%28circstats_dev_2%29.jpg