14 Replies Latest reply on Jan 14, 2016 3:06 AM by disabled_morkus

    Data Not Sometimes Saving

    JonathanHarris

      Title

      Data Not Sometimes Saving

      Post

           Several remote staff have indicated they input data on several occasions that has not saved. Please let me know what other information you would need to help me work through this issue.

            

        • 1. Re: Data Not Sometimes Saving
          philmodjunk

               What devices are they using? iOS devices or a computer?

               What software are they using? FileMaker GO, FileMaker Pro or a Web Broswer?

               Is the data stored in FileMaker tables or a remote data source such as Oracle or MySQL?

               There's a known but not yet officially confirmed issue with iOS devices using FileMaker Go not committing data--either to a local file or a hosted one. So let me know if that's the case and I'll provide a bit more info on the issue.

               If that's not the issue, you'll need, in addition to answering the above questions, describe the exact scenario. How were they entering/modifying data? How did they determine that this data was not saved?

          • 2. Re: Data Not Sometimes Saving
            JonathanHarris

                 All are working on computer and use FileMaker Pro. The data is stored in FileMaker tables on a Mac Mini-server that resides in my office. The specific issue yesterday was as follows:

                 Updated the notes for existing client on the morning of 8/14. When I checked the system last night (8/14), the notes were reverted to what was present yesterday morning (8/13).
                  
                 Not sure how much more info I can provide but will try and appreciate your assistance.
            • 3. Re: Data Not Sometimes Saving
              philmodjunk

                   The thing is, FileMaker automatically saves all data entered. There's only a very few ways that this can fail and a detailed look at exactly what the user did and exactly how the layout is designed is needed to fully analyze those possibilities.

                   Possible issues to consider:

                   The contents of a field with global storage will not be retained for a hosted database when a client of the database closes the file.

                   Some data entry layouts are set up with global fields for creating new records. The user enters data and clicks a "save" or "submit" button. That button performs a script that creates the new record and transfers the data from the global fields to the fields of this new record. If the user forgets to click that button or if something keeps that script from executing correctly, you might have an issue.

                   Sometimes users enter data and can't find it when they return because:

                   They aren't looking for it correctly. Some aspect of the data doesn't match some find criteria used and thus the data is there but they didn't find it and then assume that it was "lost".

                   A relationship or portal filter is keeping it from displaying. The data was entered, but data is lacking or different that is needed for a scripted find or relationship to match records or for a portal filter to not exclude it from a portal.

                   Another user modifies or deletes the record after the first user enters it...

                   A script run by a robot, a schedule or another user modifies or deletes it.

                   But please note the huge number of assumptions behind each of these guesses. None may apply to your specific situation.

              • 4. Re: Data Not Sometimes Saving
                ktipson

                I have just gotten notification that this has been occuring for my staff as well.  Filemaker Pro, database is hosted by Filemaker Server and they access it remotely.  They have entered information into multiple fields and then the next day the information is not there.  We just upgraded to Filemaker 14 in August and have not experienced this issue prior to the upgrade. 

                • 5. Re: Data Not Sometimes Saving
                  coherentkris

                  were they in find mode while entering the data?

                  • 6. Re: Data Not Sometimes Saving
                    ktipson

                    No, browse mode.  I can safely say this is not caused by a user mistake.  They typed into multiple fields in browse mode and the information was not there the next day.

                     

                    Sent from my iPhone

                    • 7. Re: Data Not Sometimes Saving
                      stephensexton

                      Was the information entered in a portal?  Do you create a new portal row entry via a script, rather than simply scrolling to the bottom of the portal?  I noted after updating to FileMaker Go 14 (iPad) that information appeared to be missing due to an altered behaviour of such a script.  The script involved opening a new window, switching layouts and creating a new related record, before closing the new window.  The portal would then refresh and show the new record in the top row.  In FileMaker Go 14, the same script did not seem to refresh properly and resulted in overtyping the first portal row entry (which was at the bottom of the portal out of sight).  A slight modification to the script corrected this.  However, I did not experience the same problem with FileMaker Pro??

                      • 8. Re: Data Not Sometimes Saving
                        ktipson

                        No, there are no portals in the database.

                         

                         

                        Sent from my iPhone

                        • 9. Re: Data Not Sometimes Saving
                          Elizabeth405

                          This just happened to my company as well. We have Filemaker server 14.0.1.204 installed on a Mac mini running 10.10.5. Our users are running Windows 7 Pro and Windows 8.1 Pro and Mac OSX 10.10.4. We have a database we host and all users access it through their PC's/Macs that are in-house (not over VPN). I had four users who entered data in Browse mode this morning. They are experienced users who have been using FM for over 6 years, so there is no way they were all in Find mode. They each entered their data in a text field. There are no operations that run on this field and no scripts. One user had some of his data that saved. Most of it did not. The other users' data did not save at all. We went back to our hourly backups and none of their data was there either. Three hours later the users discovered the issue and had to re-enter all their data. When they entered it the second time, it saved for all users.

                           

                          We have been using Filemaker since version 2 came out and have never seen this happen until now. It is disheartening, as we have come to rely on Filemaker more than we rely on any of our other business data systems.

                          • 10. Re: Data Not Sometimes Saving
                            ktipson

                            Elizabeth- Have you noticed any patterns as to whether this is happening more to users on a Mac than on a PC?

                            • 11. Re: Data Not Sometimes Saving
                              Elizabeth405

                              Hi. It happened over a period of two days. Three users were on PCs and two were on Macs.

                               

                               

                              Thanks,

                              Beth

                              • 12. Re: Data Not Sometimes Saving

                                Have you tried doing a commit in FM?

                                 

                                - m

                                • 13. Re: Data Not Sometimes Saving
                                  ktipson

                                  Can you explain that more?

                                  • 14. Re: Data Not Sometimes Saving

                                    Sure.

                                     

                                    Say you have a data entry form. Now as you tab to each field, FM is pretty good about saving things, but I too have noticed sometimes things don't get saved.

                                     

                                    To the rescue .... FileMaker has a commit script step that you could use on perhaps a "Save" button you put on the form or trigger in some other way.

                                     

                                    Not sure if this explicit commit will solve your actual issue(s), but it's definitely something I would try. Using an explicit commit has always solved my (uncommon) saving issues.

                                     

                                    Post back with results.

                                     

                                    - m