AnsweredAssumed Answered

Data problem?

Question asked by Wcobalt on Dec 30, 2009
Latest reply on Dec 31, 2009 by davidanders

Title

Data problem?

Post

Hi, I have a problem in our database on Filemaker Pro 9.0v1 where a field appears to have lost connection to the database engine.

 

OK, that sounds vague so here's the detail. I have a table 'Hours' which includes a field 'StaffInitials'. Looking at all records in the table (about 8,000) as a list, the field 'StaffIntials' displays properly and contains correct data. I can see (for example) a couple of hundred instances of the value 'AA'. However, when I run a find for 'AA' only a couple of records are returned, and these are created within the last couple of days.

 

To elaborate, records older than 29th December aren't found, while those later are. Searches using other fields have no problem finding all relevent records. Records include a 'Date' field - editing this makes no difference to the behaviour any record, whether created before or after the 29th.

 

I've tried duplicating an 'old' (ie prior to the 29th) record. The old record remains unfindable, while the new duplicate works fine. I've also tried manual re-entry of data into the 'StaffInitials' field of old records but this has no effect.

 

'StaffInitials' is used to create a relationship from 'Hours' to another table and, similarly, this table only shows values from records after the 29th.

 

I feel that I'm looking at a data problem that has affected records earlier than the 29th, while those created after are fully functional but I'm unsure as to how to verify this or what to do next to recover the situation

 

Any advice would be appreciated.

 

 

 

 

Outcomes