4 Replies Latest reply on Feb 4, 2014 6:51 AM by philmodjunk

    Default Radio Button in FMP 12

    RogerChristianson

      Title

      Default Radio Button in FMP 12

      Post

           I use lots of radio button fields and would like to give each set its own default value. I've tried setting the default value in the data box for auto-enter, but it doesn't seem to work. I've even shut down FMP and brought it back up to no avail. I also tried using the "calculated value" option by entering the number for the desired auto-entry in the sequence of possible entries, which also didn't work. Everyone else seems to be able to make the auto-enter data option work. What am I doing wrong? By the way, I'm using a Mac Pro running OS 10.6.8. Any suggestions?

        • 1. Re: Default Radio Button in FMP 12
          philmodjunk

               Setting a value in the data box should work, but keep these details in mind:

               Adding or changing an auto-enter field option such as a value in the Data box will not change the values shown for any existing records. Only new records will show the affects of adding/changing the auto-enter setting.

               The value you put in the data box has to exactly match a defined value in your value list or there will be no radio button to show as "selected".

               If you need to update existing records with this "default" value, use Replace Field Contents to do that.

          • 2. Re: Default Radio Button in FMP 12
            RogerChristianson

                 Thank you for your reply, PhilModJunk. I was already aware that a change would affect only new records and had tried that several times. Just to make sure that I wasn't missing something, I just went back in, copied the entry in one value list and pasted it into all of my other value lists, as well as all of the auto-reply boxes in which it occurs. Still no luck! I call up a new record and none of the radio buttons is clicked. I've had a similar problem trying to implement running and grand totals, where I follow the instructions explicitly and still get no running or grand totals. This latter problem has existed for several versions of FMP, which the former one just came up. Any other ideas?

            • 3. Re: Default Radio Button in FMP 12
              RogerChristianson

                   I've noticed that in a given table, as soon as I make one entry all of the auto-fill button auto-fill. It's as if the table doesn't respond on its own but waits for an entry before running the auto-fill script. Is there a way to tell each table to run the script when a new record is created rather than waiting for an entry to run the script, table by table?

              • 4. Re: Default Radio Button in FMP 12
                philmodjunk

                     I've used this method for years and it works just fine. But you just posted:

                     

                          Just to make sure that I wasn't missing something, I just went back in, copied the entry in one value list and pasted it into all of my other value lists, as well as all of the auto-reply boxes in which it occurs.

                     I said nothing about making changes to your value lists--which has no effect on the data already in the field. I only pointed out how it needs to work when entering the data into either the "data" box or the Specify Calculation dialog from the auto-enter tab.

                     Compare what you have tried to this demo file: https://dl.dropboxusercontent.com/u/78737945/DefaultRadioButtonDemo.fmp12

                     And summary fields work just fine to get sub totals and grand totals also....wink