3 Replies Latest reply on Oct 22, 2010 3:51 PM by ItchinaroBahnawa

    Deleting Record (FMPro menus grayed out) - Urgent

    ItchinaroBahnawa

      Title

      Deleting Record (FMPro menus grayed out) - Urgent

      Post

      I need to delete a record to fix a problem.

      We bought a POS app written on FMPro 6.  The app is no longer supported  by the developer.  The app comes in one small *.fp5 and loads of *.cji  files.

      I have two passwords for the app, normal user's and master password.   But neither allows me to delete a record (FM menus are grayed out).  I've used password crackers  to retrieve 4 additional passwords, but still cannot manually delete a  record (menus still grayed out).

      It seems to be needing developer's password.  Is there a bypass to have direct access to the records for deletion?

      I've also tried to upgrade the FM (hoping that would give me access), but the app also uses too many plugins that are not supported anymore, and upgrade is not feasible.

        • 1. Re: Deleting Record (FMPro menus grayed out) - Urgent
          RickWhitelaw

          Hi,

              You need an Admin account and password. The Privilege Set(s) you're currently using don't allow record deletion. As far as I know there's no bypass and FMI no longer recovers lost passwords. Someone else may know more . . .

          RW

          • 2. Re: Deleting Record (FMPro menus grayed out) - Urgent
            philmodjunk

            There are no admin accounts or accounts of any type in FileMaker 6 Wink.

            Have you tried performing a recover on the file? It may be that your file is damaged. Given the age of this version and the fact that you can't get any help from the original developer severely limits your options here.

            You may have no option but to export the data int a text file (if you can even do that) and import it into a brand new database designed by you or some one else.

            • 3. Re: Deleting Record (FMPro menus grayed out) - Urgent
              ItchinaroBahnawa

              I have tried recover menu item.  And it say successful, but still have the same error:

              "There was a find error.  This may be caused by a locked record.  Please verify that no other users are accessing this record and try again.  (Find Sale)"

              And of course, it's running only on one computer.  Although the developer does not support it any more, he does have on his website FAQ of this problem describing it being caused by voided transaction at the time of PC crash or some sort causing file lock.  And it suggests going in and deleting that voided record to resolve the issue.  But no way to delete that record.