7 Replies Latest reply on Aug 17, 2012 9:06 PM by TuxfordC

    Deleting Records

    TuxfordC

      Title

      Deleting Records

      Post

       Have found an oddity while testing an FM9 database. This uses three fields to record Donor_ID, Date and Amount_Given. Built in to the script is detection of  an invalid ID with a Button for deletion of a record before commital, using the Delete Record script step.  This works OK.

      However if the User chooses the Tool Bar Delete Record, all records are deleted.    I have two copies of this database. In one, all records are being deleted. In the other copy,  Tool Bar Delete Record is behaving as expected and deleting only the current record.

      Obviously there is something different , but I can not find it after several hours of looking and did not expect the Tool Bar Delete to delete the lot.  Any suggestions will be welcomed.

       

      Thanks,

      TuxfordC.

       

       

       

        • 1. Re: Deleting Records
          davidanders

          Under Record Menu
             Delete Record...   Ctrl+E
             Delete All Records

          If Control+E deletes all records, or the menu selection deletes all.

          There is a dim possibility that the database is corrupt, I have never seen this symptom.

          1] Save as smaller

          2] Open SavedAsSmaller copy and Save as Clone, import records from the original and test.

          Unlikely to solve the problem, but is a quick test.

          • 2. Re: Deleting Records
            Sorbsbuster

            Or another remote possibility is that you have a customised menu attached to the layout, and the 'Delete Record' menu has been changed to actually implement 'Delete All'.

            • 3. Re: Deleting Records
              LaRetta_1
              Also check the relationship and see if 'allow deletion of related' is checked.  If Cartesian and self-join, all records would be deleted when current record is deleted.
              • 4. Re: Deleting Records
                TuxfordC

                Yes, 'alllow deletion of related' in a self join was checked.  I unchecked and the Delete Record icon behaved correctly  However, the database copy that behaved

                properly also had' deletion of related' checked - (and the same self join) so more testing to do later on today. I would lik e to know WHY.

                Thanks,

                TuxfordC

                • 5. Re: Deleting Records
                  LaRetta_1

                  Hi TuxfordC,

                  It would depend upon the keys involved in that relationship.  One primary record might have only one related in which case only one 'related' record would delete.  But if its relational key matches more than one self-join record, it can delete more than one.  Without seeing the file, we could not say more.

                  Good luck on pinning it down; I know how it can be when the unexplained happens.  :^)

                  • 6. Re: Deleting Records
                    TuxfordC

                      My thanks for all the advice, but I am having to put this problem on the back burner. it appears that some part of the program is corrupt as I am now having lock-ups when editing scripts.   The other copy is working properly. I would like to find out why/what is happening, but need to get the database up and running to meet a user's deadline. I hope to come back to sort this out at some time in the future.

                    Thanks again,

                    TuxfordC

                    • 7. Re: Deleting Records
                      TuxfordC

                        To close off this query, I could not find any errors or oddities in the parts of the program accessible to myself, but based on the advice received earlier, I looked

                      very hard at the relationships.  So, the relationships on the Graph were deleted and replaced with identical relationships.  The problem has gone away.  Guess

                      it was something corrupt in the related software and not apparent to me.

                       

                      Thanks,

                      TuxfordC.