5 Replies Latest reply on Oct 9, 2009 8:31 AM by ChadAdams

    Disappearing records after import

    TKnTexas

      Title

      Disappearing records after import

      Post

      Several months ago I was working on linking two tables via a relationship.  No matter what was suggested it just wasn't working, and it should have.  I laid it aside for a while. 

       

      I started with a fresh table, minimal fields.  I just wanted to see for myself if it would work.  I got it to work.  In trying to go back to the original file, I saved a clone.  I deleted all relationships.  I started fresh.  I got it to work.  I was an extremely happy camper, because all of the scripts to automate the import of the text file worked.  And now with the relationship working, the two tables would be connected as they should be. 

       

      As a summary, I am importing reports that are just simple text files.  Just spooled reports.  I import to one field and using text calculations to parse out the data to other fields (ie table 1 has check number, check amount, vendor name, etc.  Table 2 has invoice information, the detail remittance information of the checks.  However since this detail does not have the check number it was a problem of linking the data to the checks.)

       

      I started the process of reimporting the source text files.  This is the new snag.

       

      I have a prompt for the check date.  Files are named using the date as part of the name.  To import the precheck register report, I have two script steps:

       

      Set the variable $filename using a calculation

      Import

       

      It finds the file and imports.  I get the information box of how many records were imported, any errors, etc.  Behind this you can see the records.  I click ok and the records delete themselves.  There is no delete command in the script.

       

      I can manually import the records and they stay.

       

      What is happening?  I am very confused.  To this date all of my imports have worked successfully if they actually find the file named in the variable.

       

      I am doing this with FMPro 10adv on XP Pro (all updates installed) on my netbook.