AnsweredAssumed Answered

Do container fields work? What am I doing wrong?

Question asked by DoubleDee on Jan 16, 2014
Latest reply on Jan 17, 2014 by philmodjunk

Title

Do container fields work? What am I doing wrong?

Post

     Hello intelligent ones,

     I'm totally stumped after hours of research and trial/error. My container fields don't work very well. All the documentation covers easily storing files and media, but nothing about how to do anything with them once they're stored. I have pored over many questions and answers about this, most of which are several years old. My issue should be simple: opening container contents to view pdf files and pictures - so they can be printed as classroom worksheets and references. My DB has several hundred lessons, all of which have resources that would be great to have access to in the DB.

     On my computers, I can save the contents every time I open one, which will quickly fill up my drive with duplicates, and seems like it should be avoidable if you don't care about editing your contents. But on FM Go, I can't do anything useful with the contents without a cumbersome work-around involving emailing myself.

     FMG: After double-clicking I have two options. 1.) I can save it. But then its lost to me since there are no file directories on the phone or iPad. Or 2.) I can email myself a copy of it, wait for the email to send, then to load, open the email, and then open the attachment from the email. Surely there's a better way. I read an older post that stated FMGo couldn't trigger other apps. That seems really weird since almost every app I have, including my own business app, can trigger other apps and open files easily.

     I'm using FMP12 on a Macbook with FMGo on various devices all using iOS6 or 7. I use an older macbook to host the DB with a static IP. I've tried various storage options for the containers but maybe I'm missing something. I have not checked my modem for new port issues, but I'm getting these difficulties at home with my MB air and a LAN. I haven't even tried this remotely yet. I've read that you can script a write-over every time you save back to the original file, but I just don't need to do all that. The files will never be modified, and that still doesn't fix the Go problem.

     Thank you for any help.

Outcomes