4 Replies Latest reply on Jul 26, 2015 9:18 AM by yomango

    Do not import first record option check

    yomango

      Title

      Do not import first record option check

      Post

      Hello. I have been encountering a problem when importing text files: I can't uncheck the "Don't import first record..."option so the first record from the text file isn't imported. I have to go to each text file I want to import and add a first line to overcome this issue. Any advise on what to do? I do not mind importing 2 or 3 files by adding a first line, but when there are hundred of text files to import, that's a problem. Please, see the attached JPG showing the issue. Thank you in advance

      importing_text_files.png

        • 1. Re: Do not import first record option check
          philmodjunk

          What file type option did you select for the import?

          • 2. Re: Do not import first record option check
            yomango

            "All files" it is the only option that will show the files. I tried all others and none showed the files

            • 3. Re: Do not import first record option check
              philmodjunk

              What version of FileMaker are you using here?

              Now that I can see your screen shot better (was using iPhone while at DevCon earlier this week.).  see the problem. The first row of data clearly does not match the correct pattern of data separated by commas found in the rest of the file. Omitting it is the only option FileMaker has to import the data successfully.

              That lone "1" for identifying the "race" needs to either be imported separately or that row of data needs to be formatted to match the subsequent rows of data.by adding a series of empty quoted strings delimited by commas.

              • 4. Re: Do not import first record option check
                yomango

                Hi, Phil. Thank you for taking the time to answer. As I said on the post , in order to get the 10 records the text file has, I have to add one more line (hence the "1") but I could have typed anything as long as it adds a new line. All that because I can't un-check the "Don't import first record..."option. I ask the FM people about it and they say it isn't a FM bug but rather the type of file being inported. So, the fastest way I came out  to get around it is to rename each file with a ".csv" extension. I then can import all 10 lines without having to add a "1" or anything in the file. It is the "best of all possible words" as far as I know. Thank you again .