2 Replies Latest reply on Aug 1, 2013 11:19 AM by ToddOrtmeier

    Dont enter default Data into Fields

    ToddOrtmeier

      Title

      Dont enter default Data into Fields

      Post

            

           I have a layout set up in my solution, and have 25+ fields that have default data set to enter into those fields upon new record creation, is there a way (shortcut key or ??) that when I make a new layout,  the default data does not populate ???
            
           every now and then I need to create a new record that doesnt have that default data, and Now I have to go back and delete all of it before I start my data entry 

        • 1. Re: Dont enter default Data into Fields
          philmodjunk

               You could add a button that runs a script for creating the new record that includes steps that clear the default data from each field.

               You could also use an auto-enter calculation instead of the data box to enter the default data and then the value in a field or variable can control whether the default data is entered into a new record:

               IF ( $$Default ; DefaultValue goes here ) //change the value of $$Default to false or empty to keep defaultvalue from being entered.

               If ( YourTable::gYourField ; Default value goes here ) // change the value of YourTable::gYourField (specify globla storage for gYourField)

               Make sure that  "do not replace existing value..." is selected so that this only occurs when the field is created.

               If you have FileMaker Advanced, you can set up a custom menu where a script replaces the New Record menu action. That scritp can use Get (ModifierKeys) to check for a modifier key being held down and it can then either modify a variable, field or clear the fields after creating the new record.

          • 2. Re: Dont enter default Data into Fields
            ToddOrtmeier

                 Several very good options, I am going to play around with them and will get back on what worked, Thanks much !!!!