2 Replies Latest reply on May 5, 2011 4:59 AM by stuartmitch

    Duplicate Entry?

    stuartmitch

      Title

      Duplicate Entry?

      Post

      Hi all,

      this is my first post here so I am, in effect, a virgin and need you to be gentle with me!

      I have created a new database using the Invoices template. I am entering my products in the Products area and in three instances I am getting a message stating that " "Part Number" is defined to contain unique values only". 

      My issue is that I only have 21 products entered so far and none of them share the Part Number I am attempting to enter. There is, clearly, something I am missing but I can't see what.

      Attached is a screenshot showing the products list. It is the three products PY-ZKBA10, PY-ZKBA6 and PY-ZKBA8 that are experiencing the problem.

      Can anyone please help?

      Cheers....Scotty

      Product_Image.PNG

        • 1. Re: Duplicate Entry?
          LaRetta_1

          Hi Scotty,

          I have reviewed this template and I see no reason you should be getting this message.  Say yes to allow duplicate value and then do View > Find and type an exclamation in the Product Number field and see if you get any results.  ! looks for duplicate entries.  Do you get any results?

          Have you changed anything on the field definition for Part Number?  I am at a loss on why it is set up on auto-enter data blank.  It certainly doesn't stop imports (with auto-enter selected) from blanking the part number; in fact, I see no purpose in it at all.  But that, I believe, is beside the point - you still shouldn't be getting this message. I cannot replicate the issue.  Has this file crashed? 

          One more thing to try:  Turn off validation unique for a moment (this must be done if we want to force indexing to refresh).  Then go to the storage tab in options.  Change indexing to 'None' and then exit field definitions back to your layout.  Then go back in and change validation back to unique.  You will not need to re-set the indexing since validation unique requires it - it will come back on automatically.

          • 2. Re: Duplicate Entry?
            stuartmitch

            Hi LaRetta,

            thanks so much for your answer and suggestions.

            I entered '!' in the find field and got no duplicates.

            I don't think I made any changes to the field definition for Part Number.

            I made the changes you suggested and then re-entered settings. Didn't appear to make any difference.

            Is there anything else I can give you that might help?

            Cheers....Scotty