7 Replies Latest reply on Apr 18, 2012 10:46 AM by philmodjunk

    email capitalised fields.

    brutuswa

      Title

      email capitalised fields.

      Post

      I do window cleaning quotes on my iPad via FMPGO12 and I've noticed that when emailing the quote which includes the clients name, address etc, which I auto capitalise, the email, when it draws info from the record shows the original text as entered... i.e. not capitalised.

      Any way around this?

      Brett

        • 1. Re: email capitalised fields.
          Sorbsbuster

          If you have formatted the field to display as Title case then that is all it is - a formatting of the way the data is displayed.  I think you will have to either capitalise the data, or you could 'convert' it for emailing using the Proper calculation; Proper ( NameField ), though a better way would be to set the fields to have an auto-enter calculation to make them convert at the point of entry.  Both will capitalise 'de Vries' as 'De Vries', for example.

          • 2. Re: email capitalised fields.
            brutuswa

            Thank you for your advice, Sorbuster

            I thought the Auto Capitalise I had set would do this but obviously not :(

            Can u indulge a neanderthal what steps to take to reflect this?

            Brett

            • 3. Re: email capitalised fields.
              Sorbsbuster

              I assume by 'auto-capitalise' you mean that you formated the field to display as Title case.

              Go to Manage Database, Field definitions, and choose in turn each of the fields you want to capitalise.  Select 'Options', then on the 'Auto-enter' tab select 'Calculated value'.  Define the calculation as:

              Proper ( [the name of the field in here] )

              Click OK.

              Untick the option to 'Do not replace existing value...'

              When you enter the name it will replace the letters you type with Title (proper) case.

              • 4. Re: email capitalised fields.
                philmodjunk

                Unfortunately, the "proper" function can mess up capitalization for name fields where it's not just the first letter capitalized.

                If someone's name should be: McDonald, it comes out as Mcdonald.

                I've used this expression as a partial solution to the problem:

                If ( Exact ( Self ; UpperSelf ) or Exact ( self ; Lower ( self ) ; Proper ( Self ) ; self )

                This only auto-capitalizes the text entered if it is either all caps or all lower case. This enables the user to override this auo-capitalizing in cases where other letters in the name should be capitalized--but relies on the person entering the name to enter it correctly.

                • 5. Re: email capitalised fields.
                  brutuswa

                  Sorbsbuster

                  I do have the Proper ( [the name of the field in here] ) bit done in the fields calculated value.

                  It seems that this merely changes the appearance of the text.  It doesn't actually change the text at all.

                  My problem is.....  When drawing the text to enter in an email, it enters in the actual text as entered (uncapitalized), not as it appears (Capitalized)

                   

                  Phil, I can see this may be a better way of doing it, but which parts of the formular are relaced by the fieldname?

                  • 6. Re: email capitalised fields.
                    Sorbsbuster

                    It works for me.  You sure you're doing as I suggested?  My test was to copy and paste the field's contents before and after the auto-enter option was applied, typing 'abc' in both cases.  One pastes as 'abc' and the other as 'Abc'.

                    Edit: to make sure it is applying the way I suggested, you should remove the Title Case formatting option, and check that it still displays as 'Abc'.

                    Edit2: Sorry - I'm trying it on a PC and FM11, not on an iPad.

                    • 7. Re: email capitalised fields.
                      philmodjunk

                      Phil, I can see this may be a better way of doing it, but which parts of the formular are relaced by the fieldname?

                      No parts are replaced by the field name. In an auto-enter calculation--which does change the actual data, not just its appearance, you can use "self" to refer to your field without using the actual name. If this gives you an error, you are either setting up a calculation field or using an older release of FileMaker.

                      With an auto-enter calculation of this sort, make sure to clear the "do not replace existing value..." option or it will not auto-correct the data entered after you exit the field.

                      Note that this change will not affect data in existing records--only those in new records that you create. For updating your existing records, see this thread for some ideas: Updating values in auto-enter calc fields without using Replace Field Contents

                      Note also that data imported into the database will not be auto-corrected unless you also enable the 'allow auto-enter options' during the import.