1 2 Previous Next 15 Replies Latest reply on Jun 25, 2010 11:29 AM by Setne007

    Entering accented characters changes text field font

    ITDept

      Title

      Entering accented characters changes text field font

      Post

      If I have an input field in FileMaker (I'm using FileMaker 10 products) set to use a specific font, such as American Typewriter Condensed, and input accented characters from the keyboard (e.g., é, ä, etc.), FileMaker changes the font to Helvetica. This seems odd, given that the fonts I'm using all support the characters I'm entering. Is there a setting in FileMaker that I'm missing that will stop this unwanted behavior? I thought "Set input method to: Synchronize with field's font" (in Field Behavior) would work, but it's not doing what I want. I've resorted to applying a calculation to strip font changes in one database, but that also seems like a ridiculous hoop to jump through to achieve my goal.

        • 1. Re: Entering accented characters changes text field font
          TSGal

          ITDept:

           

          Thank you for your post.

           

          Go into Layout Mode, select the field, pull down the Format menu and select "Font -> American Typewriter Condensed".  This sets the default font for the field.

           

          If you are entering a different Font, and you want it to automatically change back to American Typewriter Condensed, then in your field definitions, click "Options...", click the "Auto-Enter" tab, put a check mark next to "Calculated value" and enter the formula:

           

          TextFontRemove ( Self )

           

          Click OK, and then uncheck the option "Do not replace existing value of field".

           

          Now, if you are in Browse Mode, change the font to Helvetica, enter text in Helvetica and tab out of the field, the font will then change to American Typewriter Condensed.

           

          TSGal

          FileMaker, Inc.

          • 2. Re: Entering accented characters changes text field font
            ITDept
              

            TSGal wrote:

             

            Go into Layout Mode, select the field, pull down the Format menu and select "Font -> American Typewriter Condensed".  This sets the default font for the field.


            Thanks for the directions; however, the field is *already* set to American Typewriter Condensed. The problem is that as soon as I input an accented character, FileMaker changes the font to Helvetica.


            • 3. Re: Entering accented characters changes text field font
              TSGal

              ITDept:

               

              Thank you for the additional information, even though I'm puzzled, since I still cannot reproduce the problem.

               

              I'm doing this with FileMaker Pro 10.0v3 on a Mac running Mac OS X 10.5.8.  I use command-i e to get ê, command-e e to get é, command-u e to get ë, etc.  It does not change the font to Helvetica.

               

              Please create a new database file with one field "Name" of type Text.

               

              Go into Layout mode, select the field, pull down the Format menu and select "Font -> American Typewriter Condensed".  Return to Browse mode (saving the changes) and enter into the Name field: "ITDept TSGal".

               

              If everything looks correct, change the "e" in ITDept to é.  Does this work?  If this works correctly, then there may be something wrong with either the field contents, the field on the layout, or perhaps some damage with the database file.  If so, return to your original file and layout, remove the field, and drag in the same field.  Go to Browse and try again.

               

              Please continue to keep me updated.

               

              TSGal

              FileMaker, Inc.

              • 4. Re: Entering accented characters changes text field font
                ITDept
                  

                TSGal,

                 

                Thanks for continuing to offer help. I’m using FileMaker Pro Advanced 10.0v3 under Mac OS X 10.6.1 (the problem occurred under 10.5 as well). I created a new database with a single text field. FileMaker Pro Advanced set the field’s default font to Lucida Grande, which is what I have the default Roman font set to in Preferences > Fonts. Note that I also have “Synchronize input method with font on field entry” and “Use Font Locking” enabled. Mac OS X is set up to use the “U.S. Extended” Input Source (System Preferences > Language & Text > Input Sources).

                 

                I entered Layout Mode, selected the field on the layout, and explicitly set its font to American Typewriter Condensed. I then entered browse mode and input a variety of strings of plain text, such as “ITDept TSGal.” I then entered the string “büro”; immediately upon entering Option-U to start the ü, FileMaker changed the font to Lucida Grande. Note that when I went back to the previously-entered text in American Typewriter Condensed and changed the “e” in “ITDept” to “é,” FileMaker also immediately changed the font of the letter é to Lucida Grande. I verified that American Typewriter Condensed does have the accented characters in it (as it should) by selecting all text in the field and changing the font via Format > Font.

                 

                Thank you for continuing to investigate this odd problem. 

                • 5. Re: Entering accented characters changes text field font
                  comment_1
                    

                  FWIW, I can't reproduce your issue either, using exactly the same settings under OS X 10.5.8.

                   

                  Did you perhaps install a third-party American Typewriter font?

                  • 6. Re: Entering accented characters changes text field font
                    ITDept
                      

                    comment wrote:

                    FWIW, I can't reproduce your issue either, using exactly the same settings under OS X 10.5.8.

                     

                    Did you perhaps install a third-party American Typewriter font?


                     

                    That’s a good question, since I do have a variety of OpenType fonts from Adobe installed. To test it, I set the field’s font via Layout mode to Menlo (one of the new fonts Apple ships with Mac OS X 10.6) and entered an accented character. FileMaker instantly changed the font to Lucida Grande. I changed the field’s font (again, in Layout mode) to Monaco, one of the older fonts that comes with Mac OS X, and experienced the same change when I entered an accented character.

                     

                    I’ve prepared a Screen Recording (optimized for iTunes) I would be happy to share if it would help eliminate any confusion. 


                    • 7. Re: Entering accented characters changes text field font
                      Setne007

                      I have the same problem. FileMaker changes the field font to Helvetica when I enter š ā or other transliteration characters. I am using FileMaker 11 and OS 10.6.3.

                      • 8. Re: Entering accented characters changes text field font
                        Setne007

                        Now I have the same problem when I want to enter text in Hebrew. The field does not accept the formatting defined in the layout (Font and size) but keeps the formatting of the original text I am copying the Hebrew text from (Lucida Grande Unicode). Anyone who could help me fix that? (I have already clicked "Synchronize with the field's font" button, without any effect).

                        • 9. Re: Entering accented characters changes text field font
                          comment_1

                          What happens if you paste the text, then perform Undo once?

                          • 10. Re: Entering accented characters changes text field font
                            Setne007

                            It turns out Ok, with the format I want ...

                            • 11. Re: Entering accented characters changes text field font
                              comment_1

                              Well, then I'd suggest you set the field to auto-enter a calculation (replacing existing value) =

                               

                              TextFormatRemove ( Self )

                               

                              This will save you the trouble of removing the formatting by Undo or by holding the Option key while pasting.

                              • 12. Re: Entering accented characters changes text field font
                                Johan

                                I encounter the problem too. I have made all the fields correctly in FM 10.x in Frutiger Roman. All I get is Lucida Grande. Very annoying because my database, letters and invoices will not allign anymore. I have tried all the tricks, also copying, changing case in Pages and pasting it back again.

                                Please, help me with an answer, because this is all very time consuming.

                                • 13. Re: Entering accented characters changes text field font
                                  Setne007

                                   


                                  comment wrote:

                                  Well, then I'd suggest you set the field to auto-enter a calculation (replacing existing value) =

                                   

                                  TextFormatRemove ( Self )

                                   

                                  This will save you the trouble of removing the formatting by Undo or by holding the Option key while pasting.


                                   

                                  Thanks. It seems that "Undo formatting" does the trick for the new entries. Any advice on how to reformat properly all my previous entries? :-)

                                   


                                  • 14. Re: Entering accented characters changes text field font
                                    comment_1

                                    Show all records, click in the field and select Records > Replace Field Contents… > Replace with calculated result:

                                     

                                    TextFormatRemove ( YourField )

                                     

                                    Make sure you have a backup, since there is no Undo if you make a mistake.

                                    1 2 Previous Next