1 Reply Latest reply on Nov 5, 2014 7:04 AM by philmodjunk

    Error when inserting jpegs

    grouper

      Title

      Error when inserting jpegs

      Post

      Hi,

      I 've created a script that inserts files to a container from a calculated filepath. The files are all images in .jpg format.

      At first I tried the insert file option, but the container would not show the image thumbnail, just the file name. I then tried the insert picture, and got an error "this file type could not be inserted as a picture".

      When i drag and drop the same files from their folder to FM, the thumbnails work fine.

      Any advice?

      thanks

       

        • 1. Re: Error when inserting jpegs
          philmodjunk

          It sounds like your calculated file path may have an issue. Drag and drop into a container field is the equivalent of using Insert Picture to embed a copy of the file into the container field.

          One way to debug file path issues is to use the file that can be downloaded from the thread at the link I am about to post. You can insert one of these files into the container field in this file and then examine the actual file path extracted from the container field in order to see where you calculated file path may differ from the actual file path extracted from the container field.

          Exploring the use of a $Path Variable in Scripts