4 Replies Latest reply on Dec 29, 2013 8:30 AM by philmodjunk

    Estimates template problem

    PaulJones_1

      Title

      Estimates template problem

      Post

           I have a problem:-)

           i have an older database based on estimates starter solution that when i pick a contact in estimates iPad layout it will insert that customer contact as it should .

           Ive noticed also that the layout is relative to estimates database but the estimates desktop isn't ? its related to estimates 

           Now i have a more modern database from the first that ive worked on a hell of a lot and the estimates iPad doesn't work like the earlier version. The desktop version works as it should.

           if i have the iPad layout  relative to estimates layout it does nothing? it won't insert the customer details . but if i change it too estimates it inserts and works perfect.?? This is the opposite of my earlier version??

           Now i think the reason we have this estimates data and estimates is so that it gives a different estimate number to a person on the iPad from someone on the desktop. 

           If i put them both to estimates the iPad user can open the desktop last estimate and change it. I don't know if this is correct as i don't  have a genuine estimates starter solution to start from as i  think mine is corrupted. ive tried uninstall filemaker and delete the folder where the templates are kept but it keeps reinstalling.

           Has somebody got a genuine unadulterated estimates starter solution so that i can compare the layouts and the scripts to see why this is going wrong. Or is hat I'm experiencing correct and both iPad and desktop should be on "estimates" layout 

           Thanks for help 

           Paul

      Screen_Shot_2013-12-28_at_18.25.47.png

        • 1. Re: Estimates template problem
          PaulJones_1

               and the version that doesn't work but is the same as the earlier version of the same database that does work.

          • 2. Re: Estimates template problem
            philmodjunk

                 You should be able to open up the version of FIleMaker from which you got the original starter solution and use "new from starter solution" to get another working copy of that original template.

                 But I can guess as to the cause of your problem. A number of the iOS specific layouts are set up with script triggers such that the button tap that changes layouts performs a script that loads the current record's ID into a global variable before changing to a layout based on the related child table. The Match field in the child table is then set up with an auto-enter calculation that copies the value of this global variable each time a new record is created and thus the new child record is automatically linked to the parent record that is current on the layout where you tapped that button to go to the detail layout.

                 This isn't needed on the desktop layouts usually because you are entering child table data into a portal from a layout based on the parent table and the portal--based on a relationship with the "allow creation of records via this relationship" option selected for the child table does the necessary ID copying to link in the new child table for you.

            • 3. Re: Estimates template problem
              PaulJones_1

                   hi phil thanks for the reply, ive tried to open a new template but if i populate it with some products and some customers it doesn't work like my first database . it won't populate the customers when i use the customers pop up in estimates. Im therefore presuming this is somehow corrupt?. i read that they are kept on your computer not downloaded etc each time. it would be nice to get a fresh estimate template to compare scripts and layouts etc to see what my problem is.

                   As per your reply I'm assuming its script based as it works in desktop mode but not in iPad mode. 

                   Ive copied and pasted the scripts from the good database over and checked them but it still won't work. hence i wanted to try a complete new template to compare . many thanks 

                   Paul

              • 4. Re: Estimates template problem
                philmodjunk

                     There is probably a missing script trigger open Layout Set up on the layout for the parent table and check for a trigger such as OnLayoutExit.

                     From which version of FileMaker did you get this template?

                     If I knew that, I could take a closer look at the specific file or even upload the templates file to drop box for you. But usually, a corrupted file shows some behavior that is more drastic than this.