AnsweredAssumed Answered

Failure to maintain date formatting

Question asked by RickWhitelaw on Dec 27, 2010
Latest reply on Dec 27, 2010 by RickWhitelaw

Title

Failure to maintain date formatting

Post

Hi,

I'm using FMPA 11 on Mac OSX 10.6.5. I've just encountered an annoying problem that I've traced back to when I updated from FMPA 10 to 11. I have a text field auto-entered by calculation. It concatenates a five digit  field and a date field. The date field is formatted to include leading zeroes for day and month, year is four digits, and "/" is the separator. This has always generated a fifteen character string. Since FMPA11 the leading zeroes are not showing up in the resulting field. "FORUM01/02/2011" is now coming up "FORUM1/2/2011". The zeroes ARE in the date field. This has worked perfectly for years. So, a calculation that worked fine as GetAsDate(Right(PROD_DAT;10)) must now be  GetAsDate(Middle(PROD_DAT;6;10)) for it to evaluate correctly if the field is 13 or 14 characters long. 

    Am I missing something here?

RW

Outcomes