2 Replies Latest reply on Apr 29, 2014 11:54 AM by gcKoenig

    Field Color not shown when record is not current (or is  inactive?) in list view.

    gcKoenig

      Title

      Field Color not shown when record is not current (or is  inactive?) in list view.

      Post

           Boy, am I frustrated.  So many things changed in FileMaker Pro (or Advanced) 13 where they added features, but I'm having a devil of a time figuring out the difference between what seems like a bug versus what could really be an added feature instead, where there is a control for it hidden in some clever place.  I don't know what to call this 'feature' or 'bug' so it's impossible to search for it on the forum here.  There are thousands of posts listed under common words, such as "field" etc., that I don't have time to paw through them all, and "advanced" search is of little help to narrow the search results.

           Today's dilemma:  I put three small fields on a list view layout.  I made each field a separate color.  I wanted the entire 'column' of each field to appear in that color, i.e. for all records, not just the current record.  But no. The fields only show their color when the record is current.  Otherwise, they're plain white for all other records.  This used to work just fine (the way I expect it to work)  in FileMaker version 10, 11, 12, etc.

           To resolve this, I've looked and looked.  I've looked in the inspector.  The Help article "Specifying the display state for an object" says there can be 7 possible states, but when I click on one of these fields, the Inspector only shows options for four of them - "Normal," "Hover," "Pressed," and "In Focus," but not "Active," "Inactive," "Primary," or "Alternate."  Next, I checked the Inspector for the Body part.  There, it gives me "Primary," "Alternate," and "Active," but not "Normal" or "Inactive."  Looking in the part definition box was no help either.

           At the moment, I give up.  I'm moving on to accomplish something else today.  I've spent so much time trying to resolve this, I'm starting to think that it was just not worth it.

      FileMaker_Field_Color_Problem.png

        • 1. Re: Field Color not shown when record is not current (or is  inactive?) in list view.
          philmodjunk

               Open layout mode Setup and clear the "delineate" check box. When this check box is selected (and I find it truly irritating that this is the default setting for new layouts), field formatting such as the fill color is only applied to the active record.

          • 2. Re: Field Color not shown when record is not current (or is  inactive?) in list view.
            gcKoenig

                 Phil - thanks for the tip!  I had no idea what "delineate" meant!  Who would ever know this?  I agree with your comment that this is "truly irritating."  I wish the HELP system was much better, but nothing in the field 'display state' help box refers to this.  We are all left guessing.

                 I finally found the HELP article on this under the title, "Showing field borders and fill for the current record" ... which is the exact opposite of what I wanted to do.  The path for this (for others who stumble upon this post with the same problem) is this:

                 Home > Designing and creating databases > Creating and managing layouts and reports > Editing layouts > Showing field borders and fill for the current record