3 Replies Latest reply on Dec 17, 2009 1:31 PM by philmodjunk

    field data is not printing in invoice layout

    glartstudio

      Title

      field data is not printing in invoice layout

      Post

      I am using Filemaker Pro 7 for my client data and invoicing.  The total sale field on my invoice layout is missing. I did not set this up and the person who did is no longer available. I went into the layout and deleted the field and inserted again and it did not help. I changed the size of the field, the size and color of the font. I have consulted the help function of Filemaker and it did not help. Does anyone have any idea what the problem is?
      Thanks

        • 1. Re: field data is not printing in invoice layout
          philmodjunk
            

          Is the value visible in browse mode?

           

          If you click in it while in browse mode?

           

          Is this a calculation field or a summary field?

           

          If a calculation field, please post it's expression.

          • 2. Re: field data is not printing in invoice layout
            glartstudio
               <!-- StartFragment -->

            Thanks for taking the time to help me. I am sorry I did notreply sooner, I only work Monday, Tuesday, and Thursday part-time.

            The value is visible in the browse mode of the summaryrecord, not in the layout itself.

            I believe it is a summary field.

            This is strange… I clicked on the invoice button in browsemode and the invoice popped up on the screen without the field value. Then Itoggled to layout mode and back to browse mode and the value appeared. Iincluded three tiff files of a sample record to show you what happened.

            Any help you can provide it greatly appreciated.

            Thanks,file:///Users/glas/Desktop/1.tifffile:///Users/glas/Desktop/2.tifffile:///Users/glas/Desktop/3.tiff

            <!-- EndFragment -->
            • 3. Re: field data is not printing in invoice layout
              philmodjunk
                

              I haven't examined your file, but it sounds like the screen simply isn't refreshing to show the data you expect.

               

              Two script steps you can experiment with to see if they solve your problem:

               

              Commit Record

               

              Refresh Window

               

              You'll need to find the script that is performed when you click this button. You can find the name of this script by double clicking the button while in layout mode. Then you can switch to Manage Scripts and open the script for editing. Try adding each of these steps as the last step in the script and see if one of them works for you.