5 Replies Latest reply on Feb 14, 2011 2:25 PM by TimMartin

    Field issue in Layout mode and Issue with Value List from field BUG?

    TimMartin

      Title

      Field issue in Layout mode and Issue with Value List from field BUG?

      Post

      Hi, 

      I'm having a strange problem with a new database that I'm building, I think it's a bug in Filemaker. The symptom that I'm seeing is that in layout mode one of my fields is not showing it's name when I draw it onto the layout I have called it "c_superItemIDName". It is defined as If ( SuperItem = "1" ; name ; " ") the name field has a brief description of the items. the "SuperItem" field is a check box. The "c_superitemIDName" calculation is set to results are text. I have a similar field that copies the Primary Key Id called "c_superItemID" It has a similar calculation  ( SuperItem = "1" ; __PK_ID_Record ; " ") calculation is a number. This field works correctly. 

      I have a value list base on the "c_superItemID" calculation field with it displaying the "c_superitemIDName" field. This value list will only work if I do not display the "c_superitemIDName" as the display second field. What's going on?

      Thanks!

        • 1. Re: Field issue in Layout mode and Issue with Value List from field BUG?
          philmodjunk

          Is SuperItem formatted with a single checkbox or more than one? If there are more values possible than 1 and empty, you'll need to use the FilterValues function to check for your "1" value instead of using =.

          If ( not IsEmpty ( FilterValues ( SuperItem ; "1" ) ) ; name ; "" )

          • 2. Re: Field issue in Layout mode and Issue with Value List from field BUG?
            TimMartin

            SuperItem is a single check box, but that isn't where the problem is the problem is with the calculation field that I have that is putting the info in from the "name" field to the "c_SuperItemIDname" this field is behaving strangely for some reason. I tried to delete it and recreate it but I'm getting the same problems. The name of the field does not show up in layout mode when I add it to a lay out and it causes my value list to break that I have based off of the "c_SuperItemID" field. The value list works fine as long as i don't use "c_SuperItemIdName" as the second field. 

            • 3. Re: Field issue in Layout mode and Issue with Value List from field BUG?
              TimMartin

              I've attached a picture of the layout mode you can see the field next to where I have type "Super Item Name:" it's blank instead of showing "c_SuperItemName" if you select the field it will show in the inspector which field it is attached to. So something weird seems to be happening. Layout not showing field name

              • 4. Re: Field issue in Layout mode and Issue with Value List from field BUG?
                philmodjunk

                Select your field and specify black as the text color. I'm guessing that it's not visible becuase its text color has been set to white.

                I think that's a separate problem from why your value list isn't working.

                When you have two columns of data and choose to show only the data from column 2, you only get listed for each unique value from the field in column 2. I was thus exploring the Idea that this calculation field: If ( SuperItem = "1" ; name ; " ") was always returning a space instead of a name. This would happen if SuperItem = "1" is always false. Is SuperItem a number field or a text field? If it's a number field, this function should read: If ( SuperItem = 1 ; name ; " ")

                (And I'd use "" instead of " " here so that nothing is returned if SuperItem does not = 1 instead of a single space character, but you may have a reason for that value here that I don't know about.)

                • 5. Re: Field issue in Layout mode and Issue with Value List from field BUG?
                  TimMartin

                  Gosh thanks for pointing out the text color, I don't know why I didn't think of that that is why it wasn't desplaying, "Duh". I took out the quotes around the one and got rid of the space between the quotes and that got rid of the weirdness I was having. Thanks for you help! I really need to go a little bit slower on my developing and check for mistakes! Thanks again!