AnsweredAssumed Answered

Field Not Calculating Properly.

Question asked by j.hall on Jun 27, 2014
Latest reply on Jun 27, 2014 by philmodjunk

Title

Field Not Calculating Properly.

Post

     All,

     Have a good one for you this morning. So I have this field that is set as a calculation field. with this as the formula:

     (WorkOrders::OD Decimal + .07* Pi-2.4 * WOs__STRIP_ASSEMBLY_ITEMS::WT Average+ .0049999)*(WOs__STRIP_ASSEMBLY_ITEMS::WT Average*.283 *12*WOs__STRIP_ASSEMBLY_ITEMS::Length Used)

     in Watch Values window it's showing: 2286.595159014260564

     But the value that it's calculating as part of the field is: -204.636153485739436

     I have tried several things to see if I can figure out what the problem is. One of them for example was taking the field and setting it to a Number with a Calculation. When I did this and told it to replace field contents with the calculation it worked and it worked perfectly. But, when I change the filed back to a calculation field and copy and pasted the formula in. It went back to giving me the -204.6361534... number.

     I'm at a loss. Can anyone help me figure this out?

      

     TIA

     J.

Outcomes