4 Replies Latest reply on Jun 11, 2012 11:33 AM by DavidConner_1

    Field opacity issue Filemaker 12 Pro

    DavidConner_1

      Title

      Field opacity issue Filemaker 12 Pro

      Post

      Mac OsX 10.7.4

      Filemaker 12 Pro

      I've constructed a layout containing 2 fields. One field is a text field (Item) and the second field (Display_Item) is a calculation that modifies the format of the text field. This would be similar to a field containing a 10 digit phone number (4443335555) and a calculation field that would format the display ( (444) 333-5555. The plan is to place the calculated field on top of the data containing field so that it appears formated but can be edited by entering the field 'Item". I believe this is a fairly common technique.

      However, I can't seem to make the mask field completely opaque: the hidden field shows through. When viewed in list mode, the active record appears correct, but in all other records the hidden field contents are also visible. I assume I am missing something simple.

      The hidden field is set to back. The mask field is set to front. The mask field has a fill color. The hidden field is set to transparent (or set with a fill color - it shouldn't matter). The mask field is set to 100% opacity. What am I missing?

        • 1. Re: Field opacity issue Filemaker 12 Pro
          Sorbsbuster

          If your phone number example is a correct analogy then you don't have to do that.  You can have one text field, modifiable by the user, and set it to auto-enter the data in a specified format, such as the spaced and bracketed format you quote.  I think that is even the example the Help page uses to show how auto-enter by calculation can be used to format in traditional phone number fashion.

          • 2. Re: Field opacity issue Filemaker 12 Pro
            DavidConner_1

            Hi,

            Thank you for the response. I didn't realize that masking could be done using the auto-enter calculation. That will be very useful information. However, I must not have described the problem properly. The issue isn't masking a phone number field. The problem I am encountering relates to field opacity in List View. When I cover a field with an opaque, filled second field, the lower field shows through as if the top field was set to  transparent. The active record is displayed correctly (lower field hidden), but only the active record.

            This seems like it might be a feature or glitch in Filemaker 12 (or a setting I am missing). I can create a test template in Filemaker 11 with 2 fields (Front, Back). I place Front  on top of Back with Front set to a fill color and switch to List View and create several records with values in  Front and Back. In all visible records only the text from the field Front is visible. I can open (convert) the template in filemaker 12 and again everything is fine. However, if I try to construct the same test file in Filemaker 12, the front, opaque field does not hide the back field in List View except in the active record.

            • 3. Re: Field opacity issue Filemaker 12 Pro
              philmodjunk

              The auto-enter calculation does not "mask". It's an alternative approach that works much better in FileMaker than trying to set up a data input Mask.

              I'd check several setting in 12--where we all all still exploring design options.

              Is the "Delinieate..." option specified for your layout in Layout Setup...? Might need to turn it off for your layout.

              What formatting, if any, have you spedified for the "in focus" state for your "on top" field in which you are editing data?

              • 4. Re: Field opacity issue Filemaker 12 Pro
                DavidConner_1

                Thanks again. The "Delineate" option was specified for the layout. Turning this off did correct the display problem.