4 Replies Latest reply on Feb 27, 2011 12:35 AM by MTriple

    field will not fit one page and so is truncated when printed

    EmilyTaylor

      Title

      field will not fit one page and so is truncated when printed

      Post

      Please can someone help me find a way to print a record that has a long text field be printed in its entirety.

      I do not know how to change the settings so that the field which is several pages long is printed completely.

        • 1. Re: field will not fit one page and so is truncated when printed
          philmodjunk

          You can change the size of the field to be several pages long. Make it much longer than you need. Then, use the sliding options in the Position tab of the Inspector to set it to "slide up" and also "resize" enclosing part.

          • 2. Re: field will not fit one page and so is truncated when printed
            davidanders

            Print on the File Menu is an option, You can select various paper sizes there.

            If you select physical paper sizes, Legal, Letter, A3, etc, you printout will be limited to that size.

            If you select physical paper but print to PDF or other virtual paper, your results will vary.

            So your problem is that your text is too long to print on one page? Make the text smaller. Delete test.

            There are not many other options.

            • 3. Re: field will not fit one page and so is truncated when printed
              philmodjunk

              Breaking the text up in to smaller pieces and putting each block of text in to a different record may work in some situations.

              • 4. Re: field will not fit one page and so is truncated when printed
                MTriple

                According to the Help files, under Layout-> Part Setup-> select "Body" (or name of field with long text) -> press Change button -> in Part Definition window -> check both "Body" and "Allow part to break across page boundaries" and do not check "Discard remainder of part before new page," this is supposed to designate whether text is to be continued on the next page or truncated. Yet when checked the options do not work and the text is truncated whether the options are checked or not.

                The above would be the logical solution given that it is written in the Help file. Frustrating as these things can be the solution involves more than what is described in the Help file. I struggled with this and after experimenting I figured out a solution.

                The Solution:

                The key is to have the database sized to a larger paper size but when you print you select the desired paper size and the database will break up the records appropriately.

                Set up your database with a custom page size using the longest individual record. The database needs to be set up as though you intend to print it onto a paper size that will accommodate the longest page of text. For my database I created a custom paper size of 8.5x20. When you go to print, change the paper size in the operating system to the size you actually intend to print onto, (i.e. 8.5x11 Letter). The extended section of text will carry onto subsequent pages as long as you have setup the Part to do so as mentioned in my first paragraph. Follow the instructions for Removing blank spaces in printouts using Sliding/Printing (refer to the Help file) so the printer does not think every record is a long as the longest.