6 Replies Latest reply on Apr 22, 2013 2:39 PM by eneal

    Fields not showing up

    eneal

      Title

      Fields not showing up

      Post

           Hi,

           I am a new user of FMP 12 trying to learn the basics. I have established a database which initially has four tables. Each table was set up with primary and foreign key fields which show up in the form, list and table views. When I go back through the manage database option to add new fields to each table, they show up here but I cannot get them to populate the form, list and table views. Any suggestions as to what I may be doing wrong?

           Thanks

      Screen_Shot_2013-04-21_at_9.52.24_AM.png

        • 1. Re: Fields not showing up
          schamblee

               You have to create a relationship between  tables or the field has to be global.  

               See this link about creating relationship

          http://www.filemaker.com/help/html/relational.11.12.html#1028445

          • 2. Re: Fields not showing up
            eneal

                 Hi, Thanks for your answer - actually I am not having problems aligning table reltionships using matched fields - not at that stage yet. My problem is that when I define fields within a table using the 'manage database options - field' option, these new fields are not showing up within either the form, list or table view within the parent table. For example, I have a table named 'classes'. Originally when I set up the field I included the matching field key __pkClassesID. This field shows up in the different table views. However, when I went back in and added new fields 'Class Name', 'Class Location', Class Teacher' etc. these do not show up in any of the table views - only in the 'manage database' field option view. In the form, list and table views I am still only seeing '__pkClassesID. Does this make sense?

            • 3. Re: Fields not showing up
              RickWhitelaw

                   Check your preferences and make sure new fields are set to be added to the layout automatically. I don't remember the exact language.

              • 4. Re: Fields not showing up
                symbister

                     as Rick says, either you set your preferences to add newly created fields to your current layout automatically, or you add them manually once they've been created in Manage|Database|Fields

                     In Layout Mode, Select Insert>Field etc to physically place them on your layout

                • 5. Re: Fields not showing up
                  philmodjunk

                       Or just drag and drop from the field tool in your status toolbar once you have entered Layout Mode.

                  • 6. Re: Fields not showing up
                    eneal

                         Hi - Thanks for everyone's great ideas - I deleted the new copy of FM Pro 12 and then re-installed it and the problem seems to have gone away - there was a problem with disc memory when it was installed so this might have been the problem. I appreciate all the suggestions though.

                         Thanks