8 Replies Latest reply on Sep 19, 2012 1:55 AM by PhilBiker

    File access problem

    PhilBiker

      Title

      File access problem

      Post


           I have a pair of .fmp12 files - Interface & Data. I wrote some scripts yesterday to set file opening options, and must somehow have set up a security restriction, although I have no idea how. When I now try to open the Interface file, I get a dialogue box with my user name asking for a password. I have no recollection of ever having set a password in Filemaker - we have no need of any security settings for the application concerned.

           I can open the file by going via the Data file. This is set with a single view displaying a note that work should be done via the Interface file with a 'Click here' button to open the Interface file and close the Data file.

           How can I recover the situation?

           Phil

        • 1. Re: File access problem
          schamblee

               Try the default account.  User Name :  Admin and no password.

          • 2. Re: File access problem
            JimMac

                 Run "Record Recovery", then hold down ALT/Option key during start up to allow changing any Security settings.

                 Jim...

            • 3. Re: File access problem
              PhilBiker

                   Thanks for the default account suggestion - at least that lets me open the file directly. However, I need the file to be accessible without ant security questions when I hand it over to the user. So I need to remove the security settings.

                   Jim - thanks for your suggestion - I have no previous experience of this, and have failed to make any progress. I used File>Recover to create a new copy (more than once, with various options), but I can't fathom the 'ALT during startup' bit. I can't hold Alt either when starting Filemaker or when opening the file. Could you explain in more details, please.

              • 4. Re: File access problem
                philmodjunk

                     Go to File Options. There's a spot there that was originally setup to specfiy Admin and no password. Restore those settings and your file should open without the log in dialog.

                • 5. Re: File access problem
                  JimMac

                       ALT is PC, Option is Mac {same key really}

                       Double click on the FMP file in question [Interface file I assume] to launch/open the file.  Then immedialy hold down the ALT key and it will override the security for just this reason.

                       Then go after open, to menu  File | Database | Security  and set the sercutiy as S Chamblee says above.  Both files should have matched security settings.

                       Then for a test , don't do "Open Script", close FMP and restart normally.  If you are ok, then reinstate your script and try again.  Thus eliminating the script on open as the culprit.

                       Jim...

                  • 6. Re: File access problem
                    philmodjunk

                         On windows, you hold down the shift key to force the password dialog to appear.

                    • 7. Re: File access problem
                      JimMac

                           Window {shift  hmmmm makes a note}.  Phil did clarify File Option... in menu.  Both files need to be same. Plus in the Security area make sure both are FMP defaults  and the same.

                           Jim...

                      • 8. Re: File access problem
                        PhilBiker

                             Thanks, all. I sorted the problem in File>File Options and set the file to open logging in with Admin & no password. This is the same as the Data file, and nothing else needed to be changed. This must have been the original setting, and I have no idea how I upset it.

                             Phil